    <!DOCTYPE html>
<!-- Powered by RebelMouse. https://www.rebelmouse.com -->
<html lang="en">
<head prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#"><link rel="preload" as="script" href="https://www.googletagmanager.com/gtag/js?id=UA-4046244-3"><meta name="google-site-verification" content="2YXrfJRpHQac15uCn91nCrb5GyA28m77coHvParCurE" /><link rel="preload" href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjIyNi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYyOTIxODAzMX0.CPpN6yE7tjEVaaAs38BH6jzBNdLI5vlS4zphZTeRnE4/img.jpg?width=800&quality=85&coordinates=0%2C0%2C0%2C0&height=797" as="image">
    <meta name="twitter:card"               content="summary_large_image">
<meta name="twitter:site"               content="@">
<meta name="twitter:site:id"            content="">
<meta name="twitter:image"              content="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjIyNy9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY4Nzc1ODcyMH0.0rbDOyxrFVZ29PZ7wjUzOUobMMM3Ybl-B1tvFSktfwU/img.jpg?width=1200&coordinates=0%2C0%2C0%2C87&height=600">
<meta property="fb:app_id"              content="1613675565349199">
<meta property="og:type"                content="article">
<meta property="article:section"        content="Music">
        <meta property="og:url" content="https://www.okayafrica.com/african-music-songs-mhd-olamide/">
        <link rel="canonical" href="https://www.okayafrica.com/african-music-songs-mhd-olamide/" />
    <meta property="og:site_name"           content="OkayAfrica">
    
<meta property="og:image"               content="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjIyNy9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY4Nzc1ODcyMH0.0rbDOyxrFVZ29PZ7wjUzOUobMMM3Ybl-B1tvFSktfwU/img.jpg?width=1200&coordinates=0%2C0%2C0%2C87&height=600">
<meta property="og:image:width"               content="1200">
<meta property="og:image:height"               content="600">
    <meta property="og:title"               content="The 6 Songs You Need to Hear This Week">
    <meta property="og:description"         content="Featuring MHD, Olamide, Mr Drew, Yemi Alade, M3nsa x M.anifest and more.">
<meta property="article:publisher"      content="134091736609333" />

<meta name="referrer" content="always" />

    <meta charset="utf-8">
    <link rel="preconnect" href="https://assets.rebelmouse.io/" crossorigin>
    <link rel="preconnect" href="https://user-stats.rbl.ms/" crossorigin>
    <link rel="preconnect" href="https://pages-stats.rbl.ms/" crossorigin>
    <!--link rel="preload" href="https://static.rbl.ms/static/fonts/fontawesome/fontawesome-mini.woff" as="font" type="font/woff2" crossorigin-->
    <script>window.REBELMOUSE_BOOTSTRAP_DATA = {"engine": {"changeParticleUrlScroll": true, "lazyLoadShortcodeImages": true, "theoPlayerLibraryLocation": "", "defaultVideoPlayer": "", "backButtonGoToPage": true, "webVitalsSampleRate": 100, "countKeepReadingAsPageview": true, "uplynkAdsConfig": "", "trackPageViewOnParticleUrlScroll": true}, "isUserLoggedIn": false, "runner": {"id": 17424623}, "resourceId": "pp_2653791437", "section": {"id": null}, "fbId": "1613675565349199", "site": {"id": 17424623}, "messageBusUri": "wss://messages.rebelmouse.io", "tag": {"slug": "heat-of-the-week"}, "clientGaId": "UA-4046244-3", "post": {"sections": [0, 9847113, 5222116, 4945470], "shareUrl": "https%3A%2F%2Fwww.okayafrica.com%2Fafrican-music-songs-mhd-olamide%2F", "id": 2653791437}, "fbAppVersion": "v2.5", "pathParams": {"slug": "african-music-songs-mhd-olamide"}, "fullBootstrapUrl": "/res/bootstrap/data.js?path_params=%7B%22slug%22%3A%22african-music-songs-mhd-olamide%22%7D\u0026post_id=2653791437\u0026site_id=17424623\u0026override_device=desktop\u0026resource_id=pp_2653791437"};
    </script>
    <script>
        window.REBELMOUSE_BASE_ASSETS_URL = "https://www.okayafrica.com/static/dist/social-ux/";
        window.REBELMOUSE_BASE_SSL_DOMAIN = "https://www.okayafrica.com";
        window.REBELMOUSE_TASKS_QUEUE = [];
        window.REBELMOUSE_LOW_TASKS_QUEUE = [];
        window.REBELMOUSE_LOWEST_TASKS_QUEUE = [];
        window.REBELMOUSE_ACTIVE_TASKS_QUEUE = [];
        window.REBELMOUSE_STDLIB = {};
        window.RM_OVERRIDES = {};
    </script>
    <script type="module" async src="https://www.okayafrica.com/static/dist/social-ux/main.9679611b692dcc4fb3d8.bundle.mjs"></script>
    <script nomodule defer src="https://www.okayafrica.com/static/dist/social-ux/main.ab0187ad7eeca2bc3f69.bundle.js"></script>

    <script type="module" async src="https://www.okayafrica.com/static/dist/social-ux/runtime.20b527adbc76b53a4143.bundle.mjs"></script>
    <script nomodule defer src="https://www.okayafrica.com/static/dist/social-ux/runtime.add8cefce65be4cc99ac.bundle.js"></script>

    
    <!-- we collected enough need to fix it first before turn in back on-->
    <!--script src="//cdn.ravenjs.com/3.16.0/raven.min.js" crossorigin="anonymous"></script-->
    <!--script type="text/javascript">
        Raven.config('https://6b64f5cc8af542cbb920e0238864390a@sentry.io/147999').install();
    </script-->
    <script>
        if ('serviceWorker' in navigator) {
          window.addEventListener('load', function() {
            navigator.serviceWorker.register('/sw.js').then(function(registration) {
              console.log('ServiceWorker registration successful with scope: ', registration.scope);
            }, function(err) {
              console.log('ServiceWorker registration failed: ', err);
            });
          });
        } else {
          console.log('ServiceWorker not enabled');
        }
    </script>
    <script>
        // fallback error prone google tag setup
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

    

    

    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    
    
        
        <link rel="alternate" type="application/rss+xml" title="OkayAfrica" href="/feeds/music.rss" />
        
    
    


    <!-- Mobile viewport optimized: h5bp.com/viewport -->
    <meta name="viewport" content="width=device-width,initial-scale=1,minimum-scale=1.0,maximum-scale=1.0,user-scalable=no">

    

    

    

    <title>The 6 Songs You Need to Hear This Week - OkayAfrica</title>
    
    
    
    <style>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</style>
    <script>
        window.REBELMOUSE_LOW_TASKS_QUEUE.push(function() {
            window.REBELMOUSE_STDLIB.loadExternalStylesheet("/static/css-build/roar/runner/social-ux-non-critical.css?v=rmxassets49afa695b209f252e3fc9276499b6466RMCSS", function(){
                document.body.classList.add("rm-non-critical-loaded");
            });
        });
    </script>
    
    <script>
        var __RUNNER_PUBLIC__ = {
          root: '#runner-root',
          events: {
            PAGE_VIEW: 'page_view.url_change.listicle_switch_page',
            URL_CHANGE_PAGE_VIEW: 'page_view.url_change',
            LISTICLE_CHANGE_PAGE_VIEW: 'page_view.listicle_switch_page'
          }
        }
    </script>
    <script>
        window.__rebelmouseJsBaseUrl = "/static/js-build/";
        
        window.__rebelmousePrimaryColor = "rgba(91, 16, 143, 1)";
        
    </script>
    
    
    
    
    
    <link rel="apple-touch-icon"      href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8xMTQxMjk5NS8yMDAweC5qcGciLCJleHBpcmVzX2F0IjoxNjc4Mzg0MDI1fQ.em6C96FAA_G7Jk7C1XZdLDHJeNtqY8EgbDOootevKWw/img.jpg?width=192&amp;height=192" sizes="192x192"/>
<link rel="icon" type="image/png" href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8xMTQxMjk5NS8yMDAweC5qcGciLCJleHBpcmVzX2F0IjoxNjc4Mzg0MDI1fQ.em6C96FAA_G7Jk7C1XZdLDHJeNtqY8EgbDOootevKWw/img.jpg?width=32&amp;height=32"   sizes="16x16"/><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin />
    <link rel="preload" href="https://fonts.googleapis.com/css?family=Montserrat:300,400,700&display=swap" as="style" />
    <link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat:300,400,700&display=swap" /><meta property="article:published_time" content="2021-07-16T16:04:37+00:00" /><meta property="article:modified_time" content="2021-07-16T16:04:37+00:00" /><meta property="article:author" content="https://www.facebook.com/134091736609333" /><meta name="keywords" content="songs you need to hear this week, african songs, african music, afrobeats, afrobeat, afro fusion, afropop, afro pop, heat of the week"/><meta name="description" content="Featuring MHD, Olamide, Mr Drew, Yemi Alade, M3nsa x M.anifest and more."/><link rel="amphtml" href="https://www.okayafrica.com/amp/african-music-songs-mhd-olamide-2653791437"><script>
    var dfp_id__counter = 0;
    
    var dfp_slot_loaded_attr = "data-not-loaded";
    var taboola_selector = ".dfp_atf-slot[" + dfp_slot_loaded_attr + "]";
	

    function checkdfpScripts() {
        var arr = document.querySelectorAll(taboola_selector);
		
        for(var i = 0; i < arr.length; i++) {
			
            var el = arr[i];			
            dfp_id__counter++;			
			el.id="OKA_BTF_728x90_"+dfp_id__counter;
            createdfp("/1011202/OKA_BTF_728x90",[728, 90],"OKA_BTF_728x90_"+dfp_id__counter);
            el.removeAttribute(dfp_slot_loaded_attr);
        }
    }

    function createdfp(slotName,size,slotid) {
        googletag.cmd.push(function() {
			

     var slot = googletag.defineSlot(slotName,size,slotid).
         addService(googletag.pubads());
		 
		 

     // Display has to be called before
     // refresh and after the slot div is in the page.
     googletag.display(slotid);
     googletag.pubads().refresh([slot]);
   });
    }
</script><script>
googletag.cmd.push(function() {
          outstreamSLot = googletag.defineSlot('/1011202/OKA_Outstream_1x1', [1, 1], 'div-gpt-ad-1527511349153-0').addService(googletag.pubads());
	 _slot= googletag.defineSlot('/1011202/OKA_1x1_001', [1, 1], 'div-gpt-ad-1522164582731-0').addService(googletag.pubads());
	adslot1=googletag.defineSlot('/1011202/OKA_ATF_300x250',[300,250], 'OKA_ATF_300x250').addService(googletag.pubads());

adslot2=googletag.defineSlot('/1011202/OKA_BTF_300x250',[300,250], 'OKA_BTF_300x250').addService(googletag.pubads());

adslot0=googletag.defineSlot('/1011202/OKA_ATF_728x90',[[970,250],  [728,90]], 'OKA_ATF_728x90').addService(googletag.pubads());
	
//googletag.pubads().setTargeting("pagetype", "homepage");
		googletag.pubads()
	.setTargeting("pagetype", "article-"+"music")
	.setTargeting("post_id", "2653791437")
	.setTargeting("post_tags", ["songs-you-need-to-hear-this-week", "african-songs", "african-music", "afrobeats", "afrobeat", "afro-fusion", "afropop", "afro-pop", "heat-of-the-week"]);
        //googletag.pubads().setTargeting("test","rebelmouse");
	 

				
	

	// googletag.pubads().enableSyncRendering();


	googletag.pubads().enableSingleRequest();
	googletag.pubads().disableInitialLoad();
	googletag.enableServices();
});
  
   googletag.cmd.push(function() {
          googletag.display('div-gpt-ad-1527511349153-0');
          googletag.pubads().refresh([outstreamSLot]);
        });

googletag.cmd.push(function() { 
googletag.display('div-gpt-ad-1522164582731-0');
googletag.pubads().refresh([_slot]); });

  
  
   googletag.cmd.push(function() {
       if(document.getElementById('OKA_ATF_300x250')) {
      googletag.display('OKA_ATF_300x250');
       googletag.pubads().refresh([adslot1]);
    }    
        
        });

    googletag.cmd.push(function() {
          googletag.display('OKA_BTF_300x250');
          googletag.pubads().refresh([adslot2]);
        });
   
  googletag.cmd.push(function() {
         if(document.getElementById('OKA_ATF_728x90')) {
         googletag.display('OKA_ATF_728x90');
      googletag.pubads().refresh([adslot0]);
  } 
    });

  
window.ADVERT_CONFIGURATION = {
	tracking: {
		size: [1,1],
		ids: ['OKA_1x1_001','OKA_1x1_002','OKA_1x1_003']
	},
	header: {
		size: [970,250],
		responsiveSizes: [{
			viewport: [0,0],
			sizes: [ [320,50] ]
		},{
			viewport: [768,300],
			sizes: [ [728,90] ]
		},{
			viewport: [980,500],
			sizes: [ [970,250], [970,90], [728,90] ]
		}],
		ids: ['OKA_ATF_728x90']
	},
	divider: {
		size: [970,250],
		responsiveSizes: [{
			viewport: [0,0],
			sizes: [ [320,50] ]
		},{
			viewport: [768,300],
			sizes: [ [728,90] ]
		},{
			viewport: [980,500],
			sizes: [ [970,250], [970,90], [728,90] ]
		}],
		ids: ['OKA_BTF_728x90']
	},
	article: {
		size: [300,250],
		responsiveSizes: [{
			viewport: [0,0],
			sizes: [ [300,250], [320,50] ]
		},{
			viewport: [768,300],
			sizes: [ [336,280], [300,250] ]
		}],
		ids: ['OKA_ATF_300x250']
	},
	grid: {
		size: [300,250],
		responsiveSizes: [{
			viewport: [0,0],
			sizes: [ [300,250] ]
		},{
			viewport: [768,300],
			sizes: [ [728,90] ]
		},{
			viewport: [1023,500],
			sizes: [ [300,250] ]
		}],
		ids: ['OKA_ATF_300x250']
	}
};
</script><!-- Facebook Pixel Code --><noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=581561272001865&ev=PageView&noscript=1"
/></noscript><!-- End Facebook Pixel Code --><meta property="fb:pages" content="134091736609333" /><!-- Start WKND tag. Deploy at the beginning of document head. --><script>
	(function(d) {
		var e = d.createElement('script');
		e.src = d.location.protocol + '//tag.wknd.ai/4252/i.js';
		e.async = true;
		d.getElementsByTagName("head")[0].appendChild(e);
	}(document));
</script><!-- End WKND tag --><style>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</style><meta property="fb:pages" content="134091736609333" /><meta name="google-site-verification" content="fgdm1pkokeJhpfs7751ZBuByOB3inDCpDocA-s5NcOo" /><!-- Facebook Pixel Code --><noscript><img height="1" width="1" 
src="https://www.facebook.com/tr?id=1764723736944867&ev=PageView
&noscript=1"/></noscript><!-- End Facebook Pixel Code --><!-- Hotjar Tracking Code for https://www.okayafrica.com --><script> (function(h,o,t,j,a,r){ h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)}; h._hjSettings={hjid:2018996,hjsv:6}; a=o.getElementsByTagName('head')[0]; r=o.createElement('script');r.async=1; r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv; a.appendChild(r); })(window,document,'https://static.hotjar.com/c/hotjar-','.js?sv='); </script>
<meta name="google-site-verification" content="cBe5n9tBsRV5fCeFx9WGJ2OYF3_-EiBYAUx7Vrra-jM" /><style id="custom-post-styles-2653791437">
</style><style id="custom-post-styles-2653785254">
</style>

    


    <script>
    
        (function() {
    var cookie = 'rebelmouse_abtests=';
        cookie += '; Max-Age=0';
    document.cookie = cookie + '; Path=/; SameSite=None; Secure';
})();
    
    </script>


    <!--[if IE]>
        <script type="text/javascript" src="/static/js-build/libs/html5shiv/html5shiv.js"></script>
    <![endif]-->
</head>

<body 
    class="logged-out-user section-music"
 >
    <div id="fb-root"></div>
    <div id="runner-root"></div>
    
    <div id="curtain" class="curtain"></div>
    
    <nav class="menu-global">
    <div class="main-menu-wrapper">
        <div class="menu-global__search-form hide-tablet-and-desktop">
            <form action="/search/">
                <button aria-label="Submit" type="submit" class="menu-global__submit fa fa-search" value=""></button>
                <input aria-label="Search" placeholder="Search..." type="text" name="q" class="menu-global__text-input"></input>
            </form>
        </div>
        <div class="divider hide-tablet-and-desktop"></div>
        <ul class="sections-list">
    <li class="main-menu-item sections-list__item sections-list__item--home"><a href="/">Home</a></li>
    
        <li class="main-menu-item sections-list__item sections-list__item--popular">
            <a
                href="https://www.okayafrica.com/popular/"
                
            >Popular</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--spotlight">
            <a
                href="https://www.okayafrica.com/spotlight/"
                
            >Spotlight</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--audio">
            <a
                href="https://www.okayafrica.com/audio/"
                
            >Audio</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--whats-hot">
            <a
                href="https://www.okayafrica.com/whats-hot/"
                
            >What&#39;s Hot</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--video">
            <a
                href="https://www.okayafrica.com/video/"
                
            >Video</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--events">
            <a
                href="https://www.okayafrica.com/events/"
                
            >Events</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--arts--culture">
            <a
                href="https://www.okayafrica.com/arts--culture/"
                
            >Arts + Culture</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--http://okayafrica.zohorecruit.com/careers">
            <a
                href="http://okayafrica.zohorecruit.com/careers"
                target="_blank"
            >Careers</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--sudan-uprising">
            <a
                href="https://www.okayafrica.com/sudan-uprising/"
                
            >Sudan Uprising</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--diaspora">
            <a
                href="https://www.okayafrica.com/diaspora/"
                
            >Diaspora</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--afro-latino">
            <a
                href="https://www.okayafrica.com/afro-latino/"
                
            >Afro-Latino</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--in-translation">
            <a
                href="https://www.okayafrica.com/in-translation/"
                
            >In Translation</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--south-africa-reframed">
            <a
                href="https://www.okayafrica.com/south-africa-reframed/"
                
            >South Africa Reframed</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--podcasts">
            <a
                href="https://www.okayafrica.com/podcasts/"
                
            >Podcasts</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--freedom-day">
            <a
                href="https://www.okayafrica.com/freedom-day/"
                
            >Freedom Day</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--kenya">
            <a
                href="https://www.okayafrica.com/kenya/"
                
            >Kenya</a>
        </li>
    
        <li class="main-menu-item sections-list__item sections-list__item--music-brief">
            <a
                href="https://www.okayafrica.com/music-brief/"
                
            >Music Brief</a>
        </li>
    
</ul><div class="divider"></div>
        <ul id="main-menu" class="main-menu">
    <li class="main-menu-item main-menu-item--login">
        <a href="/login" class="link" title="Log in">Log in
        </a>
    </li>
</ul></div>
</nav><site_specific_data_schema></site_specific_data_schema><post_image_settings _3x2="true" _1x1="true" _3x1="true" _3x4="true" _2x1="true" _9x16="true" _16x9="true" _4x3="true"></post_image_settings><div class="all-content-wrapper">
        <div class="main v-sep">
                <span class="js-brick-description hidden" data-name="Post"></span><!-- User Code --><script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
  var adslot0;
  var adslot1;
  var adslot2;
  var _slot;
  var outstreamSLot;
</script><!-- End User Code --><div data-share-status-id="menu-toggle" data-toggle-class="menu-opened" class="menu-overlay js-toggle" data-target="body"></div><div class="" id="sTop_Bar_0_0_5_0_0_0"><!-- User Code --><div id='OKA_ATF_728x90' class="dfp_atf-slot"></div><!-- End User Code --></div><div id="sTop_Bar_0_0_5_0_0_2" class=" row-wrapper clearfix  no-mb">
    <div class="row px20">
        

<div id="sTop_Bar_0_0_5_0_0_2_0" class=" col sm-mb-2 md-mb-4 s12 m12 l12">
    <span data-triggers="render-rebelbar" class="js-scroll-trigger no-mb" data-target="body" data-toggle-class="with-fixed-header"></span><div class="topbar-wrapper" id="sTop_Bar_0_0_5_0_0_2_0_0"><div class="rebelbar rebelbar--fixed skin-simple"><div class="rebelbar__inner"><!-- User Code --><a class="rebelbar__logo--mobile" href="/"><img src="https://assets.rbl.ms/10213769/2000x.png" /></a><nav class="flex-2 rebelbar__section-links rebelbar__section-links-widelinks"><ul class="rebelbar__section-list js-overflow-box" data-target="#rebelbar__more-sections" data-loaded="true"><li><a class="rebelbar__section-link" href="/">What's Hot</a></li></ul></nav><nav class="flex-1 rebelbar__section-links"><ul class="rebelbar__section-list js-overflow-box" data-target="#rebelbar__more-sections"><li><a class="rebelbar__section-link" href="/audio">Audio</a></li><li><a class="rebelbar__section-link" href="/arts--culture">Arts + Culture</a></li><li><a class="rebelbar__section-link" href="/video">Video</a></li><li><a class="rebelbar__section-link" href="/events">Events</a><li><a class="rebelbar__section-link " href="https://shop.okayafrica.com/">Shop</a></li><li><a class="rebelbar__section-link" href="https://www.okayafrica.com/tag/South-Africa">South Africa</a></li></ul></nav><div class="social-links flex-1"><a class="social-links__link share-twitter" href="http://twitter.com/okayafrica" target="_blank"><span class="fa fa-twitter"></span></a><a class="social-links__link share-instagram" href="http://instagram.com/okayafrica" target="_blank"><span class="fa fa-instagram"></span></a><a class="social-links__link share-facebook" href="http://facebook.com/okayafrica" target="_blank"><span class="fa fa-facebook"></span></a></div><div class="search-form flex-1 hide-mobile" data-toggle-class="show-search"><form action="/search/"><input placeholder="Search" type="text" name="q" class="search-form__text-input"><button type="submit" class="search-form__submit fa fa-search" value=""></button><a class="search-form__open fa fa-search js-toggle" href="javascript:;" data-target=".search-form" data-toggle-class="show-search" data-scope="closest"></a></form></div><div data-share-status-id="menu-toggle" data-toggle-class="menu-opened" class="rebelbar__menu-toggle js-toggle flex-0" data-target="body"><i class="fa fa-bars"></i></div><style>
  .search-form__submit {
    display: none;
    position: relative;
    border: none;
    bottom: 2px;
    background-color: transparent;
  }
  
  .show-search .search-form__submit {
    display: inline-block;
    vertical-align: middle;
    padding: 0;
    color: darkcyan;
    font-size: 1.9rem;
}
  .search-form .show-search input{
  	display: block;
  }
  
  .search-form__text-input{
    display: none;
    height: 42px;
    font-size: 1.3rem;
    background-color: #f4f4f4;
    border: none;
    color: #8f8f8f;
    text-indent: 10px;
    padding: 0;
    width: 220px;
    position: absolute;
    right: -10px;
    top: 0;
    bottom: 0;
    margin: auto;
  }
 
  .fa-search:before {
    content: "\f002";
  }
</style><!-- End User Code --></div></div><div data-toggle-class="with-small-header" class="rebelbar rebelbar--fake skin-simple js-scroll-trigger" data-target="body"></div></div><div class="custom-logo" id="sTop_Bar_0_0_5_0_0_2_0_2"><div class="text-element" id="sTop_Bar_0_0_5_0_0_2_0_2_0"><a href="/" class="color-inherit" target="">okayafrica</a></div></div>
</div>


    </div>
</div>


<!-- User Code --><style>
  .around-the-web .around-the-web__headline {
visibility: hidden;
font-size: 0px;
}
.around-the-web .around-the-web__headline:after {
content: 'Related Content From Around the Web';
visibility: visible;
font-size: 1.8rem;
}
.around-the-web .from-your-site__headline {
visibility: hidden;
font-size: 0px;
}
.around-the-web .from-your-site__headline:after {
content: 'Related Articles on OkayAfrica';
visibility: visible;
font-size: 1.8rem;
}  
</style><!-- End User Code --><!-- User Code --><script>
	
		if ( window.location.pathname == '/' ||window.location.pathname == "") {
		document.querySelector('.rebelbar__section-links-widelinks .rebelbar__section-link').classList.add("active");
		}
		else {
		var section_url=window.location.href;	
		document.querySelectorAll(".rebelbar__section-link").forEach(item => {
        	var href = item.getAttribute('href');
			if(section_url.indexOf(href)>-1){
			 item.classList.add("active");
			 document.querySelector('.rebelbar__section-links-widelinks .rebelbar__section-link').classList.remove("active");
			}
		});
		}
        
document.querySelector('.sections-list').insertAdjacentHTML('beforeend','<li class="main-menu-item sections-list__item"><a class="rebelbar__section-link" href="/tag/best-of-2018">Best of 2018</a></li><div class="divider"></div><li class="main-menu-item sections-list__item sections-list__item--videos"><a href="#">Contact</a></li><li class="main-menu-item sections-list__item sections-list__item--videos"><a href="https://okayafrica.zohorecruit.com/careers">Careers</a></li><li class="main-menu-item sections-list__item sections-list__item--videos"><a href="#">Privacy Policy</a></li><li class="main-menu-item sections-list__item sections-list__item--videos"><a href="#">Terms of Use</a><div class="divider"></div></li><li class="main-menu-item sections-list__item sections-list__item--videos"><a href="https://us4.list-manage.com/subscribe?u=07504468f5b82621daca1adf9&id=6ad80cf1bb">Subscribe</a></li><li class="main-menu-item sections-list__item sections-list__item--videos"><a href="https://shop.okayafrica.com/" target="_blank">Shop</a></li>');
</script><!-- End User Code --><!-- User Code --><script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8901034631405594",
    enable_page_level_ads: true
  });
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="QuantcastElement"></span><!-- User Code --><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-6FjyzX7rRdcrz.gif" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><!-- End Quantcast tag --><!-- End User Code --><!-- User Code --><style>
.rebelbar a[href='https://www.okayafrica.com/tag/South-Africa'] {
    color: black !important;
    font-weight: bold;
	font-size: 16.8px;
	padding: 0 13px;
	transition: background-color .2s linear,color .2s linear,border-color .2s linear;
}
.rebelbar a[href='https://www.okayafrica.com/tag/South-Africa']:hover {
    color: #ffffff !important;
  	background-color: black !important;
}
  </style><!-- End User Code --><span class="js-brick-description hidden" data-name="Social Stream Element"></span><div class="post-page__content-wrapper" id="sSocial_Stream_Element_0_0_4_0_0_0"><div id="sSocial_Stream_Element_0_0_4_0_0_0_0_0" class=" row-wrapper clearfix ">
    <div class="row px20">
        

<div id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0" class=" col sm-mb-2 md-mb-4 s12 m12 l8">
    <!-- User Code --><style>
.article-description hr{
display:none
}
</style><!-- End User Code --><div class="js-section-loader-feature-container" id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0_0_1_0"><div class="" id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0_0_1_0_0"><div id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0_0_1_0_0_0" class="post-partial article__splash-custom"><div class="post-splash-custom clearfix"  data-attr-layout_primary_tag="top" data-attr-update_url_on_post_view="true" data-attr-all_share_buttons="Facebook,Twitter,Linkedin,Tumblr,Pinterest,Whatsapp,Reddit,CopyLink,Flipboard,SMS,Slack,FacebookMessenger,GooglePlus,Separator,Email" data-attr-format="splash-custom" data-attr-show_around_the_web="true" data-attr-all_element_order="primary_tag,section,author,date,photo_credit,photo_caption,headline,subheadline,body,post_shares,tags,badges,badges_sponsored,snark_line,follow_button,like_button,source_link,collection_button,main_author,page_views,community_name,community_comments,all_sections" data-attr-layout_all_date_format="%b. %d, %Y %I:%M%p EST" data-attr-layout_tags="bottom" data-attr-layout_Separator="inactive" data-attr-layout_photo_credit="bottom" data-attr-layout_post_shares="bottom" data-attr-layout_Pinterest="active" data-attr-layout_date="top" data-attr-layout_author="top" data-attr-show_full_post_body="true" data-attr-layout_photo_caption="bottom" data-attr-load_more_brick_name="_MoreFromSectionBrick" data-attr-layout_section="top" data-attr-layout_body="bottom" data-attr-id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0_0_1_0_0_0" data-attr-layout_headline="bottom" data-attr-layout_subheadline="bottom" data-attr-layout_all_image_crop="original" data-attr-layout_GooglePlus="inactive" data-attr-layout_Email="inactive" data-attr-layout_quality="5" data-attr-header_template="jinja/post/custom-css.html">
    <div class="article-module__controls-placeholder"></div>
        <span class="js-section-loader-feature js-section-loader-feature-postpage"
            data-brick="_MoreFromSectionBrick"
            data-context="sp_5222116"
            data-post-id=2653791437
            data-site-id="17424623"></span>
    
<article 
    elid="2653791437" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2653791437" 
    
    data-category="Music"
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1">
<div class="post-tags-primary">
        <a
            class="post-tags-primary-link"
            href="/tag/heat-of-the-week"
        >heat of the week</a>
</div>


    
    <span class="widget__section js-load-brick-on-click">Music</span>
    
<div class="post-author-list"><div class="post-author">
            <a href="https://www.okayafrica.com/u/okayafrica">
                <div class="post-author__avatar image" style='background-image: url("https://okayafrica.com/res/avatars/default")'></div>
            </a>
            <a href="https://www.okayafrica.com/u/okayafrica" class="post-author__name" data-type="text">OkayAfrica</a>
            
        </div></div><span class="post-date">Jul. 16, 2021 12:04PM EST</span></div><div class="widget__head">
                            
                                
                            <div class="widget__image crop-800x797"
                                    role="img"
                                    aria-label="The 6 Songs You Need to Hear This Week"
                                        
                                    style="background-image: url('https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjIyNi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYyOTIxODAzMX0.CPpN6yE7tjEVaaAs38BH6jzBNdLI5vlS4zphZTeRnE4/img.jpg?width=800&quality=85&coordinates=0%2C0%2C0%2C0&height=797'); padding-bottom: 99.625%; "
                                            
                                        data-type="image"
                            ><div class="lazyload-placeholder">
                                    <div class="runner-spinner">
                                      <svg class="runner-spinner-circular" viewBox="25 25 50 50">
                                        <circle class="runner-spinner-path" cx="50" cy="50" r="20" fill="none" stroke-width="3" stroke-miterlimit="10"/>
                                      </svg>
                                    </div>
                                </div></div>
                            
                </div><div class="widget__body clearfix sm-mt-1"><div class="photo-credit">
        Cover art for MHD's <em>Mansa</em> album.
    </div><div class="headline-container">
    <h1 class="headline h1" data-type="text">
        The 6 Songs You Need to Hear This Week
    </h1>
</div>
<div class="widget__subheadline">
    <h2 class="widget__subheadline-text h2" data-type="text"><p>Featuring <strong>MHD, Olamide, Mr Drew, Yemi Alade, M3nsa x M.anifest</strong> and more.</p></h2>
</div>
<span class="js-scroll-trigger" data-target="body" data-triggers="render-rebelbar" data-toggle-class="with-floating-shares"></span>
<div id="utm_campaign"></div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2653791437"
        
            data-elid="2653791437"
            data-post-url="https://www.okayafrica.com/african-music-songs-mhd-olamide/"
            
                data-authors="OkayAfrica"
            
            
                data-headline="The 6 Songs You Need to Hear This Week"
            
        ><div class="body-description"><p>Every week, we highlight the top releases through our <a href="https://www.okayafrica.com/tag/heat-of-the-week" target="_self">best music of the week</a> column.<br></p><p>Here's our round up of the best tracks and music videos that came across our desks, which you can also check out in our Songs You Need to Hear This Week playlists on Spotify and Apple Music.</p><p><strong>Follow our SONGS YOU NEED TO HEAR THIS WEEK playlist on <a href="https://open.spotify.com/user/okayafricaofficial/playlist/5X6P5yGBWaeroYT2yBofWH" rel="noopener noreferrer" target="_blank">Spotify here</a> and <a href="https://itunes.apple.com/us/playlist/songs-you-need-to-hear-this-week/pl.96a0f6d531a54cbb959cbc4442d310d0?mt=1&amp;app=music&amp;at=1001lph9" rel="noopener noreferrer" target="_blank">Apple Music here</a>.</strong></p><hr><p></p><div class="rebellt-item    col1" id="rebelltitem1" data-id="1" data-reload-ads="false" data-is-image="False" data-href="https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=1#rebelltitem1" data-basename="mhd-mansa-lp" data-post-id="2653791437" data-published-at="1626364769" data-use-pagination="False">
        <h3 data-role="headline">
            
                MHD 'Mansa' LP
            
            
        </h3>
        <span style="display:block;position:relative;padding-top:56.25%;" class="rm-shortcode" data-rm-shortcode-id="c634283a24670ea14a03e20e4110faff"><iframe type="lazy-iframe" data-runner-src="https://www.youtube.com/embed/jj0xIgP8VHk?rel=0" width="100%" height="auto" frameborder="0" scrolling="no" style="position:absolute;top:0;left:0;width:100%;height:100%;"></iframe></span>
        <p><strong>MHD, </strong>France's 'Afro Trap' king, is back with his new album <em>Mansa</em>. Over its 15 tracks, the young superstar continues exploring his uplifting blend of West African influences with hip-hop, dance, pop and more. <em>Mansa </em>features appearances from the likes of <strong>Naira Marley</strong> and <strong>Adekunle Gold,</strong> as well as fellow Frenchman <strong>Tiakola</strong>, who appears on lead single "Pololo" (above). <a href="https://mhd.lnk.to/Mansa" target="_blank">Listen to the whole album here</a> and revisit our <a href="https://www.okayafrica.com/mhd-afro-trap-19-interview/" target="_blank">interview with MHD</a>.</p>
<p><div class="preroll-video"></div><ora-player></ora-player></p></div>
<div class="rebellt-item    col1" id="rebelltitem3" data-id="3" data-reload-ads="false" data-is-image="False" data-href="https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=3#rebelltitem3" data-basename="olamide-julie" data-post-id="2653791437" data-published-at="1626364769" data-use-pagination="False">
        <h3 data-role="headline">
            
                Olamide 'Julie'
            
            
        </h3>
        <span style="display:block;position:relative;padding-top:56.25%;" class="rm-shortcode" data-rm-shortcode-id="1db014cf3a6d1139400f80b660615bd6"><iframe type="lazy-iframe" data-runner-src="https://www.youtube.com/embed/0BQxuWujwiw?rel=0" width="100%" height="auto" frameborder="0" scrolling="no" style="position:absolute;top:0;left:0;width:100%;height:100%;"></iframe></span>
        <p>Nigeria's <strong>Olamide</strong> continues his run from the impressive new album <em>UY Scuti</em> with this latest single, "Julie." The romantic jam sees the Nigerian heavyweight expanding and exploring his flow over a Caribbean-tinged beat. "This song is me telling my woman that I know I'm crazy and not 100% perfect, but the kind of love I get from her is so amazing I'm willing to surrender everything," Olamide says. "I wanted a mixture of that Caribbean feel just to take it away from the regular afrobeats vibe."</p>
</div>
<div class="rebellt-item    col1" id="rebelltitem2" data-id="2" data-reload-ads="false" data-is-image="False" data-href="https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=2#rebelltitem2" data-basename="m3nsa-x-m-anifest-question-for-the-gods" data-post-id="2653791437" data-published-at="1626364769" data-use-pagination="False">
        <h3 data-role="headline">
            
                M3NSA x M.anifest 'Question For The Gods'
            
            
        </h3>
        <span style="display:block;position:relative;padding-top:56.25%;" class="rm-shortcode" data-rm-shortcode-id="96d8751e9741b27a116d9b679b38fe00"><iframe type="lazy-iframe" data-runner-src="https://www.youtube.com/embed/wqoEy3pXRjw?rel=0" width="100%" height="auto" frameborder="0" scrolling="no" style="position:absolute;top:0;left:0;width:100%;height:100%;"></iframe></span>
        <p>Ghanaian rappers <strong>M3NSA</strong> and <strong>M.anifest</strong> connect for a new collaboration that asks many questions about social injustices while keeping things light and funny, throwing in some jokes everyone will relate to from daily life. They both really go in with their flows over this airy <strong>Rvdical The Kid</strong>-produced beat. Get into it above.</p>
<p><div class="dfp_atf-slot" data-not-loaded="true"></div><script type="text/javascript"> 
    checkdfpScripts();
</script></p></div>
<div class="rebellt-item    col1" id="rebelltitem6" data-id="6" data-reload-ads="false" data-is-image="False" data-href="https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=6#rebelltitem6" data-basename="mr-drew-pains" data-post-id="2653791437" data-published-at="1626451477" data-use-pagination="False">
        <h3 data-role="headline">
            
                Mr Drew 'Pains'
            
            
        </h3>
        <span style="display:block;position:relative;padding-top:56.25%;" class="rm-shortcode" data-rm-shortcode-id="46b4378fc000a7d0ec80d907b66dabf9"><iframe type="lazy-iframe" data-runner-src="https://www.youtube.com/embed/v969ZymMsyw?rel=0" width="100%" height="auto" frameborder="0" scrolling="no" style="position:absolute;top:0;left:0;width:100%;height:100%;"></iframe></span>
        <p>Ghana's buzzing <strong>Mr Drew </strong>shares the new single and music video for his latest jam "Pains." The track, produced by fellow Ghanaian <strong>Beatz Vampire</strong>, will grab your ears with its mix of afro-fusion and drill elements. It all makes for a hard-hitting song that we can see getting plenty of replays. </p>
</div>
<div class="rebellt-item    col1" id="rebelltitem4" data-id="4" data-reload-ads="false" data-is-image="False" data-href="https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=4#rebelltitem4" data-basename="yemi-alade-enjoyment" data-post-id="2653791437" data-published-at="1626451477" data-use-pagination="False">
        <h3 data-role="headline">
            
                Yemi Alade 'Enjoyment'
            
            
        </h3>
        <span style="display:block;position:relative;padding-top:56.25%;" class="rm-shortcode" data-rm-shortcode-id="01a8ba64717951d6682e728c5a5e1d47"><iframe type="lazy-iframe" data-runner-src="https://www.youtube.com/embed/e5jX2eYYvpY?rel=0" width="100%" height="auto" frameborder="0" scrolling="no" style="position:absolute;top:0;left:0;width:100%;height:100%;"></iframe></span>
        <p>The queen <strong>Yemi Alade</strong> comes through over a fast-paced, <strong>Dr. Amir</strong>-produced dance beat in her latest single "Enjoyment." The track, as its title implies, is simply about enjoying one's self without remorse. Get into it above</p>
</div>
<div class="rebellt-item    col1" id="rebelltitem5" data-id="5" data-reload-ads="false" data-is-image="False" data-href="https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=5#rebelltitem5" data-basename="dagizah-who-goes-there" data-post-id="2653791437" data-published-at="1626451477" data-use-pagination="False">
        <h3 data-role="headline">
            
                Dagizah 'Who Goes There'
            
            
        </h3>
        <iframe src="https://open.spotify.com/embed/album/1Wr6g6jCiR74ff2RCNTnBI" width="100%" height="380" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe>
        <p>Here's a new one from up-and-coming Nigerian artist <strong>Dazigah. </strong>"Who Goes There" continues his explorations in mixing the elements of Fuji music with drill music to make for a catchy track to soundtrack your summer. Listen above.</p>
</div><p></p><h2>Follow our SONGS YOU NEED TO HEAR THIS WEEK playlist on <a href="https://open.spotify.com/user/okayafricaofficial/playlist/5X6P5yGBWaeroYT2yBofWH" rel="noopener noreferrer" target="_blank">Spotify here</a> and <a href="https://itunes.apple.com/us/playlist/songs-you-need-to-hear-this-week/pl.96a0f6d531a54cbb959cbc4442d310d0?mt=1&amp;app=music&amp;at=1001lph9" rel="noopener noreferrer" target="_blank">Apple Music here</a>.</h2><p><br></p><div class="rm-embed embed-media"><iframe allow="encrypted-media" allowtransparency="true" frameborder="0" height="380" src="https://open.spotify.com/embed/playlist/5X6P5yGBWaeroYT2yBofWH" width="100%"></iframe></div><p><br></p><div class="rm-embed embed-media"><iframe allow="autoplay *; encrypted-media *; fullscreen *" frameborder="0" height="450" sandbox="allow-forms allow-popups allow-same-origin allow-scripts allow-storage-access-by-user-activation allow-top-navigation-by-user-activation" src="https://embed.music.apple.com/us/playlist/songs-you-need-to-hear-this-week/pl.96a0f6d531a54cbb959cbc4442d310d0" style="width:100%;max-width:660px;overflow:hidden;background:transparent;"></iframe></div><p><br></p><div class="post-pager js-listicle-pager" data-listicle-style="" data-async_load_parameters="platform=desktop&amp;display_ads=1&amp;settings=%7B%22enter_url%22%3A+false%2C+%22no_post_section%22%3A+false%2C+%22ads_breaks%22%3A+null%2C+%22prevent_last_break_repetition%22%3A+false%2C+%22use_numeration%22%3A+false%2C+%22show_columns_on_mobile%22%3A+false%2C+%22ads_order%22%3A+%5B%5D%2C+%22turn_into_posts%22%3A+false%2C+%22list_breaks%22%3A+null%2C+%22reorder_voting%22%3A+false%2C+%22cooldown_in_seconds%22%3A+null%2C+%22pagination_order%22%3A+%5B%5D%2C+%22source%22%3A+%22post_listicle_settings%22%2C+%22next_post_url%22%3A+null%2C+%22up_down_voting%22%3A+false%2C+%22allow_url_change%22%3A+true%2C+%22numeration_sort%22%3A+-1%2C+%22allow_url_update%22%3A+true%2C+%22use_pagination%22%3A+false%2C+%22body_text_above%22%3A+false%2C+%22use_ads%22%3A+false%2C+%22items_as_posts%22%3A+false%2C+%22multiple_answers%22%3A+false%2C+%22no_redirect%22%3A+false%2C+%22is_guest_voting_allowed%22%3A+true%2C+%22layout_type%22%3A+1%2C+%22voting_extra_fields%22%3A+%7B%7D%7D">
</div><div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div>
        <ul class="around-the-web__list"><li class="from-your-site__item">
                        <a href="https://www.okayafrica.com/mtv-africa-music-awards-2021-listener-choice-nominees/" class="from-your-site__link" target="_blank" rel="noopener noreferrer">MTV Africa Music Awards Announces Top 20 'Listener's Choice ... &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://www.okayafrica.com/brian-eno-edikanfo-ghanaian-classic-1981/" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Edikanfo, a Brian Eno-Produced Ghana Classic Gets Reissued ... &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://www.okayafrica.com/museke-online-african-music-awards-winners/" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Museke Online African Music Awards Winners - OkayAfrica &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://www.okayafrica.com/african-afrobeats-dance-pop-culture-crossover-moments-2018-beyonce-rihanna-diddy-janet-jackson/" class="from-your-site__link" target="_blank" rel="noopener noreferrer">7 Crossover Moments That Highlight Africa's Influence on Pop ... &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://www.okayafrica.com/south-africa-musica-to-close-shop/" class="from-your-site__link" target="_blank" rel="noopener noreferrer">End of an Era as Last South African Music Shops Set to Close ... &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://www.okayafrica.com/the-lion-king-a-music-story-presented-by-disney/" class="from-your-site__link" target="_blank" rel="noopener noreferrer">The Lion King: A Music Story | Presented by Disney - OkayAfrica &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://www.okayafrica.com/african-music-festivals-best-2018/" class="from-your-site__link" target="_blank" rel="noopener noreferrer">The 10 Best African Music Festivals - OkayAfrica &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://www.okayafrica.com/vintage-african-music-records-you-need-in-your-life/" class="from-your-site__link" target="_blank" rel="noopener noreferrer">9 Vintage African Records You Need in Your Life - OkayAfrica &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://www.okayafrica.com/sample-chief-african-music-samples-interpolations-lyrics-site-/" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Sample Chief, a Go-To Platform for African Music Knowledge, Share ... &rsaquo;</a>
                    </li></ul></div></div>
        

        

    </div>



<span class="js-scrolled-url"
    data-elid="2653791437"
    data-post-url="https://www.okayafrica.com/african-music-songs-mhd-olamide/"
    
        data-authors="OkayAfrica"
    
    
        data-headline="The 6 Songs You Need to Hear This Week"
    >
</span>

    
    
<script type="application/json" id="post-context-2653791437">
    {"customDimensions": {"1":"OkayAfrica","2":"music","3":"songs you need to hear this week, african songs, african music, afrobeats, afrobeat, afro fusion, afropop, afro pop, heat of the week","4":"07/16/2021"}, "post": {"providerId": 0, "sections": [0, 9847113, 5222116, 4945470], "buckets": [], "authors": [17428355]} }
</script><div class="widget__shares share-panel">
    <!-- FACEBOOK -->
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.okayafrica.com%2Fafrican-music-songs-mhd-olamide%2F%3Fxrs%3DRebelMouse_fb%26ts%3D1626451477" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- TWITTER -->
<a href="https://twitter.com/intent/tweet?url=https://www.okayafrica.com/african-music-songs-mhd-olamide/&amp;text=The%206%20Songs%20You%20Need%20to%20Hear%20This%20Week&amp;" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- TUMBLR -->
<a href="https://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.okayafrica.com%2Fafrican-music-songs-mhd-olamide%2F&amp;name=The%206%20Songs%20You%20Need%20to%20Hear%20This%20Week" data-track-share="Tumblr" class="share share-popup share-tumblr" rel="noopener noreferrer" aria-label="Share on Tumblr"><i aria-hidden="true" class="icons-share tl fa fa-tumblr"></i></a><!-- PINTEREST -->
<a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.okayafrica.com%2Fafrican-music-songs-mhd-olamide%2F&amp;media=https%3A//assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjIyNi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYyOTIxODAzMX0.CPpN6yE7tjEVaaAs38BH6jzBNdLI5vlS4zphZTeRnE4/img.jpg%3Fwidth%3D600&amp;description=The%206%20Songs%20You%20Need%20to%20Hear%20This%20Week" data-track-share="Pinterest" class="share share-pinterest share-popup" rel="noopener noreferrer" aria-label="Save to Pinterest"><i aria-hidden="true" class="icons-share pt fa fa-pinterest"></i></a><!-- REDDIT -->
<a href="http://www.reddit.com/submit?url=https://www.okayafrica.com/african-music-songs-mhd-olamide/" data-track-share="Reddit" class="share share-popup share-reddit" rel="noopener noreferrer" aria-label="Share on Reddit"><i aria-hidden="true" class="icons-share rd fa fa-reddit-alien"></i></a><!-- SMS -->
</div><div class="tags">
        
            <a
                class="tags__item"
                href="https://www.okayafrica.com/tag/songs-you-need-to-hear-this-week"
            >songs you need to hear this week</a>
        
            <a
                class="tags__item"
                href="https://www.okayafrica.com/tag/african-songs"
            >african songs</a>
        
            <a
                class="tags__item"
                href="https://www.okayafrica.com/tag/african-music"
            >african music</a>
        
            <a
                class="tags__item"
                href="https://www.okayafrica.com/tag/afrobeats"
            >afrobeats</a>
        
            <a
                class="tags__item"
                href="https://www.okayafrica.com/tag/afrobeat"
            >afrobeat</a>
        
            <a
                class="tags__item"
                href="https://www.okayafrica.com/tag/afro-fusion"
            >afro fusion</a>
        
            <a
                class="tags__item"
                href="https://www.okayafrica.com/tag/afropop"
            >afropop</a>
        
            <a
                class="tags__item"
                href="https://www.okayafrica.com/tag/afro-pop"
            >afro pop</a>
        
            <a
                class="tags__item"
                href="https://www.okayafrica.com/tag/heat-of-the-week"
            >heat of the week</a>
        
    </div></div></div></div>
    
    
<script type="application/json" id="post-context-2653791437">
    {"customDimensions": {"1":"OkayAfrica","2":"music","3":"songs you need to hear this week, african songs, african music, afrobeats, afrobeat, afro fusion, afropop, afro pop, heat of the week","4":"07/16/2021"}, "post": {"providerId": 0, "sections": [0, 9847113, 5222116, 4945470], "buckets": [], "authors": [17428355]} }
</script>
</article>
</div>
</div></div></div><div class="" id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0_0_4"><!-- User Code --><div class="dfp_atf-slot" data-not-loaded="true"></div><!-- End User Code --></div>




<div
        class="wrapper-lazy-loading infinite-scroll-wrapper next-page-wrapper"
        style="display: block !important;"
        
    data-skl-id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/if[is_desktop==true]/row/column[1]/if[post_page==true]/lazyload-"
    data-has-more="true"
    data-more-posts-exists="true"
    data-posts-sources="related"
    data-ignore-page-number="false"

>
    
</div>
<div class="infinite-scroller " id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0_1"><div class="mb-2 " id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0_1_0"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="section_1"
        data-format="posts-custom"
        data-source="current_page"
        data-source-type="page"
        data-source-unique="true"
        data-section-id="0"
        data-is-reordable="true"
        data-using-stickers="true"
        data-has-more="true"

    
        data-attr-layout_columns="1"
        data-attr-source="current_page"
        data-attr-update_url_on_post_view="true"
        data-attr-all_share_buttons="Facebook,Twitter,Linkedin,Tumblr,Pinterest,Whatsapp,Reddit,CopyLink,Flipboard,SMS,Slack,GooglePlus,Separator,Email"
        data-attr-format="posts-custom"
        data-attr-all_element_order="section,author,date,photo_credit,headline,subheadline,body,post_shares,badges,badges_sponsored,snark_line,follow_button,community_comments,like_button,source_link,collection_button,page_views,tags,main_author,community_name,photo_caption,primary_tag,all_sections,date_modified"
        data-attr-layout_all_date_format="%b. %d, %Y %I:%M%p EST"
        data-attr-layout_Separator="inactive"
        data-attr-source_unique="true"
        data-attr-element_classes=""
        data-attr-section_url=""
        data-attr-layout_mobile_image_crop="1x1"
        data-attr-layout_vertical_separation="24"
        data-attr-data-rm-advanced="true"
        data-attr-source_url="current_page"
        data-attr-layout_photo_credit="bottom"
        data-attr-layout_Linkedin="active"
        data-attr-without_current="true"
        data-attr-layout_post_shares="bottom"
        data-attr-layout_date="top"
        data-attr-layout_author="top"
        data-attr-posts_id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0_1_0"
        data-attr-layout_image_column_width="20"
        data-attr-headline_text=""
        data-attr-load_more_brick_name="_MoreFromSectionBrick"
        data-attr-limit="1"
        data-attr-v="2"
        data-attr-layout_section="top"
        data-attr-layout_all_show_video="true"
        data-attr-layout_body="bottom"
        data-attr-layout_headline="bottom"
        data-attr-layout_subheadline="bottom"
        data-attr-layout_horizontal_separation="0"
        data-attr-layout_all_image_crop="original"
        data-attr-node_id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/if[is_desktop==true]/row/column[1]/element_wrapper/posts-"
        data-attr-layout_GooglePlus="inactive"
        data-attr-layout_Email="inactive"
        data-attr-load_more_button_text="+ Training"
        data-attr-data-rm-device-crops="true"
        data-attr-source_id="current_page"
        data-attr-layout_quality="5"
        data-attr-header_template="jinja/post/custom-css.html">
    <div class="posts-wrapper clearfix">
            
                <span class="js-section-loader-feature js-section-loader-feature-container"
                    data-brick="_MoreFromSectionBrick"
                    data-context="sp_4944329"
                    data-post-id=2653785254
                    data-site-id="17424623">
                
                <div class="widget tag-jamal-ademola tag-mixed-media-artist-and-filmmaker tag-i-forever-am tag-i-dreamed-of-seeing-myself tag-portrait-of-dionne tag-who-should-i-be-in-the-world tag-african-ancient-futures tag-nigeria tag-ihuoma-ofordire tag-ethel-ruth-tawe tag-a-white-space-creative-agency tag-yrsa-daley-ward tag-arts-and-culture" 
                 elid="2653785254"
                data-category="Popular">
<article 
    elid="2653785254" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2653785254" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1">

    
    <a
        class="widget__section js-load-brick-on-click"
        href="https://www.okayafrica.com/popular/"
    >Popular</a>
    



<div class="social-author clearfix">
    

    
        
    <div class="social-author__avatar image" >
             <div class="cover-all image" style='background-image: url("https://okayafrica.com/res/avatars/default")'></div>
        </div>
        <a class="social-author__name" href="https://www.okayafrica.com/u/audrey_lang" data-type="text">Audrey Lang</a>
        
</div>
<div class="social-date">
        <span class="social-date__text">Jul. 14, 2021 11:49PM EST</span>
    </div></div><div class="widget__head"><a href="https://www.okayafrica.com/spotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media/"  aria-label="Spotlight: Jamal Ademola&#39;s Exploration Of Self-Identity Through Mixed Media">
                            
                            <div class="widget__image crop-1080x1350"
                                    role="img"
                                    aria-label="Spotlight: Jamal Ademola&#39;s Exploration Of Self-Identity Through Mixed Media"
                                        
                                    data-runner-img-hd="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODU4MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0MzY0ODExMH0.9EZDifCsGvDFPDm83PGTmsx-G1D7eYDU-pp4Li3QOAw/img.jpg?width=1200&amp;height=1500"
                                    data-runner-img-md="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODU4MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0MzY0ODExMH0.9EZDifCsGvDFPDm83PGTmsx-G1D7eYDU-pp4Li3QOAw/img.jpg?width=600&amp;height=750"
                                    data-runner-img-sd="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODU4MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0MzY0ODExMH0.9EZDifCsGvDFPDm83PGTmsx-G1D7eYDU-pp4Li3QOAw/img.jpg?width=300&amp;height=375"
                                    data-runner-style='padding-bottom: 125.0%;'
                                    style='padding-bottom: 125.0%;'
                                        data-type="image"
                            ><div class="lazyload-placeholder">
                                    <div class="runner-spinner">
                                      <svg class="runner-spinner-circular" viewBox="25 25 50 50">
                                        <circle class="runner-spinner-path" cx="50" cy="50" r="20" fill="none" stroke-width="3" stroke-miterlimit="10"/>
                                      </svg>
                                    </div>
                                </div></div>
                            </a>
                </div><div class="widget__body clearfix sm-mt-1"><div class="photo-credit">
        Supplied
    </div><h1 class="widget__headline h1">
    <a class="widget__headline-text custom-post-headline" href="https://www.okayafrica.com/spotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media/"  aria-label="Spotlight: Jamal Ademola&#39;s Exploration Of Self-Identity Through Mixed Media" data-type="text">
        Spotlight: Jamal Ademola&#39;s Exploration Of Self-Identity Through Mixed Media
    </a>
</h1>
<div class="widget__subheadline">
    <h2 class="widget__subheadline-text h2" data-type="text"><p>Journey with Nigerian-American mixed media artist and filmmaker Jamal Ademola as he strolls towards self-discovery.</p></h2>
</div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2653785254"
        
            data-elid="2653785254"
            data-post-url="https://www.okayafrica.com/spotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media/"
            
                data-authors="Audrey Lang"
            
            
                data-headline="Spotlight: Jamal Ademola&#39;s Exploration Of Self-Identity Through Mixed Media"
            
        ><div class="body-description"><div class="widget__brief"><p><em>In our '</em><a href="http://okayafrica.com/tag/spotlight" rel="noopener noreferrer" target="_blank"><em>Spotlight</em></a><em>' series, we highlight the work of photographers, visual artists, multimedia artists and more who are producing vibrant, original work. In our latest piece, we spotlight Nigerian-American mixed media artist and filmmaker </em><em>Jamal Ademola</em>. <em>His work was featured in an exhibition titled, "AFRICAN ANCIENT FUTURES" curated by </em><a href="https://www.instagram.com/artofetheltawe/?hl=en" rel="noopener noreferrer" target="_blank"><u><em>Ethel Tawe</em></u></a><em> at A Whitespace Creative Agency in Lagos, Nigeria from</em> <em>February 28th to April 2nd. </em><em>The exhibition featured the black experience through an afro-surrealist lens. Follow Jamal's work on </em><a href="https://www.instagram.com/jamalademola/?hl=en" rel="noopener noreferrer" target="_blank"><u><em>Instagram</em></u></a><em> and on his </em><a href="http://jamalademola.com/work/" rel="noopener noreferrer" target="_blank"><u><em>site</em></u></a><em>. </em></p><p>Nigerian-American mixed media artist and filmmaker <strong>Jamal Ademola </strong>effectively works across multiple mediums — film, visual art, video, drawing, painting, photography, and performance that creates conversations around such themes as black identities, the divine feminine, cultural consciousness and society. The dreamworlds he erects are indicative of an awareness of self and others that is otherworldly. His knack for storytelling and love for fine art permeate throughout his body of work.</p><p><div class="preroll-video"></div><ora-player></ora-player></p></div>
            <div class="content-container"></div>
            <div class="js-appear-on-expand"><template><p>Where in work <em><strong>I FOREVER AM</strong>, </em>Jamal attempts to paint a clearer picture of the black experience, <em><strong>I DREAMED OF SEEING MYSELF</strong> </em>strings together pieces of our collective history. Prints like <em>'<strong>WHO SHOULD I BE IN THE WORLD?' </strong></em>and <em><strong>'PORTRAIT OF DIONNE' </strong></em>place women at the forefront of the overall story Jamal wants to tell. </p><p>Below, he shares his views on identity. </p><p><em>Responses have been edited for length and clarity.</em></p><p><em></em><strong>Tell me about the journey you walked to become the artist you are today?</strong></p><p>I've always been artistic and creative. Since age three, my mother noticed that I would draw inside all of her encyclopedias. Like a lot of Black artists, I didn't know what I was doing was art. I was just being creative. And it wasn't until I went to school for media arts and animation in 2000 that I realized this...I dropped out of Georgia State where I'd been studying computer science. Like a lot of children born to African parents, I didn't have a lot of support for a career in the arts. I didn't know how I'd make a living being creative.</p><p><div class="dfp_atf-slot" data-not-loaded="true"></div><script type="text/javascript"> 
    checkdfpScripts();
</script></p><p>I was very rebellious. I went to school for animation but ended up dropping out. I went to one of those for-profit schools which wasn't that great. I started working in television and got into design and different mediums. I wanted to stretch out and expand into photography, filmmaking, and even acting. I found myself very drawn to lots of different things. My mind just wanted to find a way to combine different mediums into a new visual language. </p><p>About six years ago, I started taking my artistic practice more seriously. Before that I was doing, and still do, a lot of advertising projects like commercials and other stuff — these are usually animated or mixed media.</p><p class="shortcode-media shortcode-media-rebelmouse-image">
        <img id="82e66" data-rm-shortcode-id="0d184836b54597ea49182fa1784a2da2" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201080%201080'%3E%3C/svg%3E" data-runner-src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODg1Mi9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY3NDYzNjgwOX0.7LYL3qPBiIU1KG02wuYiuUqOfYlRDjx8mwOwtUuPmak/img.gif?width=980" width="1080" height="1080">
        
        
        <small class="image-media media-caption" placeholder="Add Photo Caption...">"I FOREVER AM"</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Supplied</small></p><p><strong>Tell us about <em>"I FOREVER AM"</em>, the piece which you featured in the exhibit "AFRICAN ANCIENT FUTURES" in Lagos.</strong><br></p><p>I wrote a poem in 2020 when I was feeling really down. There was a lot of collective sadness following <strong>Ahmaud Arbery</strong>'s killing, then <strong>George Floyd </strong>and <strong>Breonna Taylor</strong>. It was around Juneteenth. </p><p>I write poetry sometimes, but don't really publish a lot of it. I wanted to make something that was an affirmation. It felt like collectively, in the black and African consciousness or in the diaspora, our lived experience was always about oppression and struggle. We were seeing these images of us being killed regularly. It has been going on for Centuries, we're just catching it more on camera and that, to me, isn't the totality of the African story or the completeness of the Black experience. Our history is not just about that. </p><p><em><strong>"I FOREVER AM" </strong></em>was this sort of cosmic affirmation that we are an incredible people that can exist beyond that narrative. I collaborated with a few artists on that piece. I asked<strong> Ihuoma Ofordire</strong> to help out because I wanted a female voice to embody this divine consciousness. I wanted this to go beyond gender. It was really important for it to not just be a male voice. I wanted it to feel more like a collective voice. I also collaborated with Tunde Adebimpe; he sang this poem that I'd written. I had no immediate plan to show this work. Then <strong>Ethel Ruth Tawe</strong> was curating <strong>AFRICAN ANCIENT FUTURES</strong> at "<a href="https://aw-ca.com/" rel="noopener noreferrer" target="_blank"><u>A White Space Creative Agency</u></a>" in Lagos, Nigeria and she wanted to show some of my work. Then it became more of, '<em>How can we make this work in a gallery?</em>' '<em>How can we make this look interesting and have a flow or tell a story as people move through the gallery?</em>' </p><p><strong>The piece <a href="https://vimeo.com/519162912" rel="noopener noreferrer" target="_blank"><u>"</u><u><em>I DREAMED OF SEEING MYSELF"</em></u></a> seems like a continuation of the aforementioned. Is that the case?</strong></p><p>That's a film starring phenomenal poet and actress <strong>Yrsa Daley-Ward </strong>where I wanted to show something specific for the AFRICAN ANCIENT FUTURES exhibition that was made with Ethel's curatorial statement in mind. By juxtaposing surrealist narrative and taking the immense history that we share, and then also thinking about Afro-Now-ism in the future and Afrofuturism. That piece became a triptych of different pieces strung together for the screening.</p><p class="shortcode-media shortcode-media-rebelmouse-image">
        <img id="e6182" data-rm-shortcode-id="1319999ed38383767e389c8abfaf3801" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201080%201236'%3E%3C/svg%3E" data-runner-src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODg1NC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0Mjg4MTA3Nn0.PlkF8DJs-paV_s5SjiBwZchMXc87QjSxwbhXNUBi1R0/img.jpg?width=980" width="1080" height="1236">
        
        
        <small class="image-media media-caption" placeholder="Add Photo Caption...">An installation view of "I DREAMED OF SEEING MYSELF"</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Supplied</small></p><p><strong>Despite most descriptions of your works detailing the future, dreams, and the black identity, you don't consider yourself an afro-futurist. Why is that?</strong><br></p><p>Part of the film <a href="https://vimeo.com/519162912" rel="noopener noreferrer" target="_blank"><u>"</u><u><em>I DREAMED OF SEEING MYSELF</em></u><u>"</u></a> is about taking back our power to tell our own stories and define our realities. I had no real qualms with the term Afrofuturism until I discovered that it was a white male writer that created it. Finding that out made me consider the importance of controlling our own images and narratives. We don't even control our own descriptions of ourselves. It's hard for me to embrace it wholeheartedly even though I know that its intentions are good. And that is to essentially, radically envision ourselves in the future. Terms like Afro-Now-ism speculate on the possibilities that exist within the unencumbered Black mind, and this term was created by a Black woman. </p><p><strong>Where do you draw inspiration from?</strong> </p><p>I have so many interests. Music is a huge inspiration. Oftentimes, when I'm writing or creating, I'm listening to music. Films and nature inspire me too. In visual media, there are a lot of artists that I'm inspired by...probably too many to name. I'm also inspired by my experiences and a lot of personal observations of our society and the quirky little things that we do as human beings.</p><p><br></p><p class="shortcode-media shortcode-media-vimeo">
        <iframe src="https://player.vimeo.com/video/320811956" width="100%" height="480" frameborder="0" scrolling="no" class="rm-shortcode" data-rm-shortcode-id="50b10ce5927e41bec2db6658ccb381e6"></iframe>
        </p><p><br></p><p><strong>What central themes are consistently found in your work?</strong><br></p><p>I lived in Lagos for 10 years, and my family emigrated to Atlanta when I was 11. That was a big culture shock! I find that that's the quintessential African story, we're always migrating or emigrating. Sometimes we're escaping civil war, or some colonial destabilization, of our homeland in hopes of a better life. I find that that really permeates a lot of my work—telling, or wanting to tell, those stories of identity and displaced identity. How do you retain your African identity when you live in the West?</p><p>I feel westernized whenever I go back to Nigeria. Then you start questioning yourself despite knowing you're African and knowing you're Black. It's funny because before you were Black, you were African and then you got to America and now you're Black. There's just all these labels that one needs to sift through to get to self-discovery. The themes are migration, identity, self discovery, self-actualization, transformation, taking ownership, and taking back your power.</p><p class="shortcode-media shortcode-media-rebelmouse-image">
        <img id="50758" data-rm-shortcode-id="899c27ac53341879431e1a9766f1b467" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201080%201362'%3E%3C/svg%3E" data-runner-src="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODg1Ny9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0MDA1MTY1Mn0.ySCwELEI_IpcEaMlwfvxhd_6c5d9_LwxVLFtTWAsRvE/img.jpg?width=980" width="1080" height="1362">
        
        
        <small class="image-media media-caption" placeholder="Add Photo Caption...">"WHEN THE SLEEPER AWAKES" by Jamal Ademola</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Supplied</small></p><p><strong>Tell us about your penchant for putting women at the center of your work.</strong><br></p><p>I'm inspired by black women. I wrote my first script in 2013 and feel like there's now a push to tell women-centered stories. Intuitively, I just felt like they were more interesting. The dominant mainstream society was always told more from a male point of view. I was trying to tell more women's stories because we don't get to see a lot of those. </p><p>I feel like every human being has both a masculine and feminine energy. Being an artist, I'm allowed to explore the more feminine side of myself when photographing women or trying to tell a story from their point of view. It allows me to tap into aspects of myself that I don't get to discover often. </p><p><strong>You work across so many mediums. Do you have a preferred medium?</strong> </p><p>At one point, I felt like I always had to choose one medium to be taken seriously as an artist or a creator. If you're doing too many things, people have a hard time identifying you in a certain way. If I had to box myself in, I would say storytelling and fine art. There's always a narrative present for me. Even if I take a photograph, sometimes I'll do a narration or if it's a film, I'll interview someone, and they'll do the narration. My work is always centered around a story. </p></template></div>
            <div class="widget__show-more with-primary-color js-keep-reading js-page-view-and-reload-embeds">
                <span class="show-more js-expand">Keep reading...</span>
                <span class="show-less js-contract">Show less</span>
            </div></div>
        

        

    </div>

<span class="js-scrolled-url"
    data-elid="2653785254"
    data-post-url="https://www.okayafrica.com/spotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media/"
    
        data-authors="Audrey Lang"
    
    
        data-headline="Spotlight: Jamal Ademola&#39;s Exploration Of Self-Identity Through Mixed Media"
    >
</span>
<div class="widget__shares share-panel">
    <!-- FACEBOOK -->
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.okayafrica.com%2Fspotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media%2F%3Fxrs%3DRebelMouse_fb%26ts%3D1626383119" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- TWITTER -->
<a href="https://twitter.com/intent/tweet?url=https://www.okayafrica.com/spotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media/&amp;text=Spotlight%3A%20Jamal%20Ademola%27s%20Exploration%20Of%20Self-Identity%20Through%20Mixed%20Media&amp;" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- LINKEDIN -->
<a href="http://www.linkedin.com/shareArticle?mini=false&amp;url=https://www.okayafrica.com/spotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media/&amp;" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a><!-- TUMBLR -->
<a href="https://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.okayafrica.com%2Fspotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media%2F&amp;name=Spotlight%3A%20Jamal%20Ademola%27s%20Exploration%20Of%20Self-Identity%20Through%20Mixed%20Media" data-track-share="Tumblr" class="share share-popup share-tumblr" rel="noopener noreferrer" aria-label="Share on Tumblr"><i aria-hidden="true" class="icons-share tl fa fa-tumblr"></i></a><!-- PINTEREST -->
<a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.okayafrica.com%2Fspotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media%2F&amp;media=https%3A//assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODU4MC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0MzY0ODExMH0.9EZDifCsGvDFPDm83PGTmsx-G1D7eYDU-pp4Li3QOAw/img.jpg%3Fwidth%3D600&amp;description=Spotlight%3A%20Jamal%20Ademola%27s%20Exploration%20Of%20Self-Identity%20Through%20Mixed%20Media" data-track-share="Pinterest" class="share share-pinterest share-popup" rel="noopener noreferrer" aria-label="Save to Pinterest"><i aria-hidden="true" class="icons-share pt fa fa-pinterest"></i></a><!-- REDDIT -->
<a href="http://www.reddit.com/submit?url=https://www.okayafrica.com/spotlight-jamal-ademola-s-exploration-of-self-identity-through-mixed-media/" data-track-share="Reddit" class="share share-popup share-reddit" rel="noopener noreferrer" aria-label="Share on Reddit"><i aria-hidden="true" class="icons-share rd fa fa-reddit-alien"></i></a><!-- SMS -->
</div></div></div></div>
    
    
<script type="application/json" id="post-context-2653785254">
    {"customDimensions": {"1":"Audrey Lang","2":"popular","3":"jamal ademola, mixed media artist and filmmaker, i forever am, i dreamed of seeing myself, portrait of dionne, who should i be in the world?, african ancient futures, nigeria, ihuoma ofordire, ethel ruth tawe, a white space creative agency, yrsa daley-ward, arts and culture, ~popular_source-pageview","4":"07/15/2021"}, "post": {"providerId": 0, "sections": [0, 4944329, 501393245, 9683830, 5208991], "buckets": [], "authors": [17428502]} }
</script>
</article>
                </div>
            </span>
    </div>
</div>
    

    

    
    
            
            
            
            
            
            
            
            </div><div class="" id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_0_1_1"><!-- User Code --><div class="dfp_atf-slot" data-not-loaded="true"></div><script type="text/javascript" > 
  checkdfpScripts();
</script><!-- End User Code --></div>




<div
        class="wrapper-lazy-loading infinite-scroll-wrapper next-page-wrapper"
        style="display: block !important;"
        
    data-skl-id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/if[is_desktop==true]/row/column[1]/element_wrapper/lazyload-"
    data-has-more="true"
    data-more-posts-exists="true"
    data-posts-sources="current_page"
    data-ignore-page-number="false"

>
    
</div>
</div>



 
    <div class="infinite-scroll-wrapper next-page-wrapper hidden"
        style="display: block !important;"
        
    data-skl-id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/if[is_desktop==true]/row/column[1]/element_wrapper-"
    data-has-more="true"
    data-more-posts-exists="true"
    data-posts-sources="current_page"
    data-ignore-page-number="false"

    >
        <div class="infinite-scroll-loader"></div>
    </div>

</div>


    
    
    

<div id="sSocial_Stream_Element_0_0_4_0_0_0_0_0_1" class=" col sm-mb-2 md-mb-4 s12 m12 l4">
    <span class="js-brick-description hidden" data-name="Side Bar"></span><div id="sSide_Bar_0_0_3_0_0_0" class=" row-wrapper clearfix ">
    <div class="row px20">
        

<div id="sSide_Bar_0_0_3_0_0_0_0" class=" col sm-mb-2 md-mb-4 s12 m12 l12">
    <div class="" id="sSide_Bar_0_0_3_0_0_0_0_0"><div style_subscription-widget_all_default_padding="20px 0 27px" style_subscription-widget_mobile_default_padding-bottom="15px" style_subscription-widget_all_default_background="transparent" class="subscription-widget clearfix sm-mb-2" id="sSide_Bar_0_0_3_0_0_0_0_0_0"><div class="sm-mb-2" id="sSide_Bar_0_0_3_0_0_0_0_0_0_0"><div class="module-headline">
    <h1 class="module-headline__text h1">
        get okayafrica in your inbox
    </h1>
</div><div class="newsletter-element__form get-alerts clearfix"><input placeholder="Enter Email..." type="email" class="newsletter-element__input" id="newsletter-email"></input><label class="accesibility-hidden" for="newsletter-email">Enter Email...</label><button class="newsletter-element__submit">Join</button></div></div></div><div class="" id="sSide_Bar_0_0_3_0_0_0_0_0_1"><!-- User Code --><iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fokayafrica&width=62&layout=button&action=like&size=large&show_faces=false&share=false&height=28&locale=en_US" width="65" allowTransparency="true" scrolling="no" class="sidebar__follow-facebook" frameborder="0" height="28"></iframe><iframe src="https://platform.twitter.com/widgets/follow_button.html?screen_name=okayafrica&show_screen_name=false&show_count=false&size=l" class="sidebar__follow-twitter" title="Follow Viralized on Twitter" width="70" height="28"></iframe><a href=" https://www.instagram.com/okayafrica/" class="sidebar__follow-instagram" target="_blank"><i class="fa fa-instagram"></i>Follow</a><style type="text/css">
	.sidebar__follow-instagram {
    line-height: 28px;
    display: inline-block;
    color: #fff;
    font-size: 13px;
    width: 80px;
    height: 28px;
    border-radius: 3px;
    background-image: linear-gradient(150deg, #405de6, #833ab4 25%, #fd1d1d 70%, #ffdc80);
    vertical-align: top;
    text-align: center;
margin-left:6px;
}
.sidebar__follow-instagram .fa.fa-instagram {
    font-size: 18px;
    top: 2px;
left:-5px;
    position: relative;
}#twitter-widget-0 { 
	height: 28px;
	    margin-left: 3px;
	    position: relative;
	    visibility: visible;
	    width: 71px;
		vertical-align:top;
	}
.sidebar__follow-twitter {
    border: none;
    overflow: hidden;
    width: 80px;
    height: 37px;
    vertical-align: top;
    margin-left: 6px;
}


@media all and (max-width:333px){ 
   .sidebar__follow-instagram{ 
      margin-top: 10px;
   }
}
</style><!-- End User Code --></div></div><div class="" id="sSide_Bar_0_0_3_0_0_0_0_1"><!-- User Code --><div id='OKA_ATF_300x250' class="dfp_atf-slot"></div><!-- End User Code --></div>




<div
        class="wrapper-lazy-loading infinite-scroll-wrapper next-page-wrapper"
        style="display: block !important;"
        
    data-skl-id="/root/blocks/block[side_bar]/abtests/abtest[1]/row/column/lazyload-"
    data-has-more="true"
    data-more-posts-exists="true"
    data-posts-sources="current_page"
    data-ignore-page-number="false"

>
    
</div>


<div id="sSide_Bar_0_0_3_0_0_0_0_3"  class="rm-sticky-parent" >
    <span class="js-scroll-trigger" data-scope="next" data-triggers="sticky" data-target="#sticky-target-sSide_Bar_0_0_3_0_0_0_0_3" data-offset="50" data-toggle-class="sticky-active"></span>
    <div id="sticky-target-sSide_Bar_0_0_3_0_0_0_0_3" class="sticky-target">
        <div class="" id="sSide_Bar_0_0_3_0_0_0_0_3_0"><div class="mb-2 " id="sSide_Bar_0_0_3_0_0_0_0_3_0_0"><div class="module-headline">
    <h1 class="module-headline__text h1">
        popular.
    </h1>
</div><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="section_2"
        data-format="posts-custom"
        data-source="current_page"
        data-source-type="page"
        data-source-unique="true"
        data-section-id="0"
        data-is-reordable="true"
        data-using-stickers="true"
        data-has-more="true"

    
        data-attr-source_unique="true"
        data-attr-posts_id="sSide_Bar_0_0_3_0_0_0_0_3_0_0"
        data-attr-layout_headline="bottom"
        data-attr-section_url=""
        data-attr-layout_subheadline="bottom"
        data-attr-source="current_page"
        data-attr-layout_vertical_separation="24"
        data-attr-headline_text="popular."
        data-attr-format="posts-custom"
        data-attr-layout_all_image_crop="2x1"
        data-attr-node_id="/root/blocks/block[side_bar]/abtests/abtest[1]/row/column/sticky/element_wrapper/posts-"
        data-attr-source_url="current_page"
        data-attr-without_current="true"
        data-attr-all_element_order="headline,subheadline,section,author,date,badges,badges_sponsored,photo_credit,body,snark_line,post_shares,follow_button,community_comments,like_button,source_link,collection_button,community_name,photo_caption,page_views,tags,primary_tag,main_author,all_sections"
        data-attr-limit="1"
        data-attr-v="2"
        data-attr-source_id="current_page"
        data-attr-layout_quality="1">
    <div class="posts-wrapper clearfix">
            
                
                <div class="widget tag-makho-ndlovu tag-mkabayi-ka-jama tag-yaa-asantewaa tag-endubis tag-zimbabwe tag-bulawayo tag-joshua-mqabuko-nkomo-international-airport tag-o-r-tambo-international-airport tag-oprah-winfrey tag-sustainable-developmental-goals tag-african-diaspora tag-africa tag-nomfundo-makhubu tag-pan-africanism-ideology tag-black-identity tag-identity-politics" 
                 elid="2653783921"
                data-category="Featured">
<article 
    elid="2653783921" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2653783921" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__head"><a href="https://www.okayafrica.com/discrimination-against-black-people/"  aria-label="Where Can We Be Black In Peace?">
                            
                            <div class="widget__image crop-2x1"
                                    role="img"
                                    aria-label="Where Can We Be Black In Peace?"
                                        
                                    data-runner-img-hd="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODIxOC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY2ODkwODcyOH0.hxtw0rthg_0ntRITTNq3ywtcX7G2DLHB7JIPvqlYx_U/img.jpg?width=1200&quality=85&coordinates=0%2C432%2C0%2C432&height=600"
                                    data-runner-img-md="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODIxOC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY2ODkwODcyOH0.hxtw0rthg_0ntRITTNq3ywtcX7G2DLHB7JIPvqlYx_U/img.jpg?width=600&quality=85&coordinates=0%2C432%2C0%2C432&height=300"
                                    data-runner-img-sd="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk1ODIxOC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY2ODkwODcyOH0.hxtw0rthg_0ntRITTNq3ywtcX7G2DLHB7JIPvqlYx_U/img.jpg?width=600&quality=85&coordinates=0%2C432%2C0%2C432&height=300"
                                    data-runner-style='padding-bottom: 50.0%;'
                                    style='padding-bottom: 50.0%;'
                                        data-type="image"
                            ><div class="lazyload-placeholder">
                                    <div class="runner-spinner">
                                      <svg class="runner-spinner-circular" viewBox="25 25 50 50">
                                        <circle class="runner-spinner-path" cx="50" cy="50" r="20" fill="none" stroke-width="3" stroke-miterlimit="10"/>
                                      </svg>
                                    </div>
                                </div></div>
                            </a>
                </div><div class="widget__body clearfix sm-mt-1"><h1 class="widget__headline h1">
    <a class="widget__headline-text custom-post-headline" href="https://www.okayafrica.com/discrimination-against-black-people/"  aria-label="Where Can We Be Black In Peace?" data-type="text">
        Where Can We Be Black In Peace?
    </a>
</h1>
<div class="widget__subheadline">
    <h2 class="widget__subheadline-text h2" data-type="text"><p>Nomfundo Makhubu reckons that Africa is the only place in the world where Black people can exist peacefully, sans any scrutiny or whatever seeks to discredit our identity. But first, we need to fix the continent, she argues.</p></h2>
</div></div></div></div>
    
    
<script type="application/json" id="post-context-2653783921">
    {"customDimensions": {"1":"Nomfundo  Makhubu","2":"carousel-news","3":"makho ndlovu, mkabayi ka jama, yaa asantewaa, endubis, zimbabwe, bulawayo, joshua mqabuko nkomo international airport, o.r. tambo international airport, oprah winfrey, sustainable developmental goals, african diaspora, africa, nomfundo makhubu, pan-africanism ideology, black identity, identity politics","4":"07/15/2021"}, "post": {"providerId": 0, "sections": [0, 9847113, 5208863], "buckets": [], "authors": [22739050]} }
</script>
</article>
                </div>
    </div>
</div>
    

    

    
    
            
            
            </div><div class="" id="sSide_Bar_0_0_3_0_0_0_0_3_0_1"><!-- User Code --><div id='OKA_BTF_300x250' class="dfp_atf-slot"></div><!-- End User Code --></div></div>
    </div>
    	
        	
        	
    
</div>
</div>


    
    
    
    </div>
</div>



        
        
        
        
        
        
        
</div>


    </div>
</div>



        
        
        
        
        
        
        <!-- User Code --><style>
  
  .photo-caption > p {
   margin-left: 0 !important; 
    margin-top: 0 !important;
  }
  
</style><!-- End User Code --></div><!-- User Code --><!-- /1011202/OKA_Outstream_1x1 --><div id='div-gpt-ad-1527511349153-0' style='height:1px; width:1px;'></div><!-- End User Code --><!-- User Code --><!-- /1011202/OKA_1x1_001 --><div id='div-gpt-ad-1522164582731-0' style='margin-bottom:0'></div><!-- End User Code --></div>
            </div>



    
    


    
    


    



    

    

    

    

    
    


    

    

<ul id="notification" class="notification"></ul>




    
    <script defer src="https://www.googletagmanager.com/gtag/js?id=UA-4046244-3"></script><script>

            (function (i, s, o, g, r, a, m) {
                i["GoogleAnalyticsObject"] = r;
                (i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments);}),(i[r].l = 1 * new Date());
            })(window, document, "script", "/", "ga");
            ga('create', 'UA-4046244-3', 'auto', {'name': 'b'});

            window.dataLayer = window.dataLayer || [];
            window.gtag = function(){dataLayer.push(arguments);}
            gtag('js', new Date());

            var utmCampaignData = null;
                            utmCampaignData = {
                                'campaignName': "use_light_social_ux_app,1",
                                'campaignSource': "",
                                'campaignMedium': "",
                                'campaignContent': "",
                                'campaignKeyword': "",
                                'dataSource': "abtest"
                            };// ADD REFERRER AS SOURCE IF SOURCE IS NOT PRESENT OR IF ISN'T URL UTM
            if(utmCampaignData && (utmCampaignData.dataSource != "url" || !utmCampaignData['campaignSource'])) {
                var referrerAnchor = document.createElement('a');
                referrerAnchor.setAttribute('href', document.referrer);
                if(referrerAnchor.href && referrerAnchor.host) {
                    var splitHost = referrerAnchor.host.split(".");
                    var nakedDomain = splitHost.length < 3 ? splitHost[0] : splitHost[1];
                    if (nakedDomain) {
                        nakedDomain = nakedDomain[0].toUpperCase() + nakedDomain.substring(1);
                        utmCampaignData['campaignSource'] = nakedDomain;
                    }
                }
            }

            var configParams = { transport: 'beacon', send_page_view: false };
            // DEFAULTS
            if (utmCampaignData) {
                configParams.campaignName = utmCampaignData.campaignName;
                configParams.campaignSource = utmCampaignData.campaignSource;
                configParams.campaignMedium = utmCampaignData.campaignMedium;
                configParams.campaignContent = utmCampaignData.campaignContent;
                if (utmCampaignData.campaignKeyword) {
                    configParams.campaignKeyword = utmCampaignData.campaignKeyword;
                }
            }

            gtag('config', 'UA-4046244-3', configParams);

            <!-- ga_custom_dimensions: {u'postTags': 3, u'authorName': 1, u'sections': 2, u'postDate': 4, u'layoutId': 5} -->

          window._ga_cd_params = {};
          window._ga_cd_params["dimension1"] = "OkayAfrica";
          
          window._ga_cd_params["dimension3"] = "songs you need to hear this week, african songs, african music, afrobeats, afrobeat, afro fusion, afropop, afro pop, heat of the week";
          
          window._ga_cd_params["dimension2"] = 'music';
          
          window._ga_cd_params["dimension4"] = '07/16/2021';
          
          
          
          
          
          window._ga_cd_params["dimension5"] = 'use_light_social_ux_app,1';
          
            if(window._ga_cd_params && Object.keys(window._ga_cd_params).length){
                gtag('event', 'page_view', window._ga_cd_params);
            }else{
                gtag('event', 'page_view');
            }
        </script>
    
    
    <script>
        if (typeof window.gtag === 'function') {
            var anchors = document.getElementsByTagName('a');
            for(var i = 0; i < anchors.length; i++) {
                var elem = anchors[i];
                elem.addEventListener('click', function (evnt) {
                    if (document.location.hostname === evnt.currentTarget.hostname) {
                        return;
                    }
                    if (!evnt.currentTarget.href) {
                        return;
                    }
                    if (evnt.currentTarget.href.lastIndexOf('javascript:', 0) === 0) {
                        return;
                    }
                    window.gtag('event', 'click', {
                        'event_category': 'outgoing_links',
                        'event_action': 'click',
                        'event_label': evnt.currentTarget.href,
                        'nonInteraction': 1,
                    });
                }, false);
            }
        }
    </script>
    
        <script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type":  "NewsArticle" ,
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.okayafrica.com/african-music-songs-mhd-olamide/"
        },
        "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/",
        "headline": "The 6 Songs You Need to Hear This Week",
        "thumbnailUrl": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjIyNi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYyOTIxODAzMX0.CPpN6yE7tjEVaaAs38BH6jzBNdLI5vlS4zphZTeRnE4/img.jpg?width=210",
        "image": {
            "@type": "ImageObject",
            "url": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjIyNy9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY4Nzc1ODcyMH0.0rbDOyxrFVZ29PZ7wjUzOUobMMM3Ybl-B1tvFSktfwU/img.jpg?width=1200&coordinates=0%2C0%2C0%2C87&height=600",
            "width": 1200,
            "height": 600
        },
        "datePublished": "2021-07-16T16:04:37Z",
        "dateModified": "2021-07-16T16:04:37Z",
        "author": {
            "@type": "Person",
            "name": "OkayAfrica"
        },
        "publisher": {
        "@type": "Organization",
        "name": "OkayAfrica",
        "logo": {
            "@type": "ImageObject",
            "url": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yMzE0NjAyOC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY4NzUwMjM5OX0.PPRezlP0qNsrDW6OPR6sO0l7lmfc3U8K2tqPlUhgB8k/img.png?width=210"
            }
        },
        "articleSection": "Music",
        "description": "Featuring MHD, Olamide, Mr Drew, Yemi Alade, M3nsa x M.anifest and more.",
        "keywords": ["songs you need to hear this week", "african songs", "african music", "afrobeats", "afrobeat", "afro fusion", "afropop", "afro pop", "heat of the week"]}
</script><script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "ItemList",
                "itemListElement": [
                            {
                                "@type": "ListItem",
                                "position": "1",
                                "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=1#rebelltitem1",
                                "name": "MHD 'Mansa' LP","image": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjE4MS9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY4NDg2MTU5N30.hIeUHxrzBEP2JpeWdEv3PqAIluwubzHueS5-14TPDMM/img.jpg?width=980"},
                            {
                                "@type": "ListItem",
                                "position": "2",
                                "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=3#rebelltitem3",
                                "name": "Olamide 'Julie'","image": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjE3NC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY1NDc5ODAwOH0.9nIm9IgndlJ9ms8NKTecE8iX3ZL8RJ6xCzPsgv8TcQo/img.jpg?width=980"},
                            {
                                "@type": "ListItem",
                                "position": "3",
                                "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=2#rebelltitem2",
                                "name": "M3NSA x M.anifest 'Question For The Gods'","image": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2MTQ3Ny9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzNDQzNjE1OX0.405QwJXdHPIaodaTwxNx4prMSjbwX4xTklZBjEeVfNg/img.jpg?width=980"},
                            {
                                "@type": "ListItem",
                                "position": "4",
                                "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=6#rebelltitem6",
                                "name": "Mr Drew 'Pains'","image": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjI0Mi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY3NzE3ODcwMX0.mwtjqYWNsyET02AEWK0U2Ot9yKGOlUSVNdidAY-C2xo/img.jpg?width=980"},
                            {
                                "@type": "ListItem",
                                "position": "5",
                                "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=4#rebelltitem4",
                                "name": "Yemi Alade 'Enjoyment'","image": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjIzNi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY1NDc5NTExNH0.MpMiyK9tSGFcuomXZJVkRsgayjLO-BUWkcvs7YKdiD8/img.jpg?width=980"},
                            {
                                "@type": "ListItem",
                                "position": "6",
                                "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=5#rebelltitem5",
                                "name": "Dagizah 'Who Goes There'"}]
            }
        </script><script type="application/ld+json">
        {
            "@context": "https://schema.org",
            "@type": "VideoObject",
            "name": "MHD 'Mansa' LP",
            "description": "\u003cp\u003e\u003cstrong\u003eMHD, \u003c/strong\u003eFrance's 'Afro Trap' king, is back with his new album \u003cem\u003eMansa\u003c/em\u003e. Over its 15 tracks, the young superstar continues exploring his uplifting blend of West African influences with hip-hop, dance, pop and more. \u003cem\u003eMansa \u003c/em\u003efeatures appearances from the likes of \u003cstrong\u003eNaira Marley\u003c/strong\u003e and \u003cstrong\u003eAdekunle Gold,\u003c/strong\u003e as well as fellow Frenchman \u003cstrong\u003eTiakola\u003c/strong\u003e, who appears on lead single \"Pololo\" (above). \u003ca href=\"https://mhd.lnk.to/Mansa\" target=\"_blank\"\u003eListen to the whole album here\u003c/a\u003e and revisit our \u003ca href=\"https://www.okayafrica.com/mhd-afro-trap-19-interview/\" target=\"_blank\"\u003einterview with MHD\u003c/a\u003e.\u003c/p\u003e",
            "thumbnailUrl": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjE4MS9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY4NDg2MTU5N30.hIeUHxrzBEP2JpeWdEv3PqAIluwubzHueS5-14TPDMM/img.jpg?width=980",
            "uploadDate": "2021-07-16T16:04:37Z",
            "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=1#rebelltitem1",
            "contentUrl": "https://youtu.be/jj0xIgP8VHk",
            "embedUrl": "https://youtu.be/jj0xIgP8VHk"
        }
    </script><script type="application/ld+json">
        {
            "@context": "https://schema.org",
            "@type": "VideoObject",
            "name": "Olamide 'Julie'",
            "description": "\u003cp\u003eNigeria's \u003cstrong\u003eOlamide\u003c/strong\u003e continues his run from the impressive new album \u003cem\u003eUY Scuti\u003c/em\u003e with this latest single, \"Julie.\" The romantic jam sees the Nigerian heavyweight expanding and exploring his flow over a Caribbean-tinged beat. \"This song is me telling my woman that I know I'm crazy and not 100% perfect, but the kind of love I get from her is so amazing I'm willing to surrender everything,\" Olamide says. \"I wanted a mixture of that Caribbean feel just to take it away from the regular afrobeats vibe.\"\u003c/p\u003e",
            "thumbnailUrl": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjE3NC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY1NDc5ODAwOH0.9nIm9IgndlJ9ms8NKTecE8iX3ZL8RJ6xCzPsgv8TcQo/img.jpg?width=980",
            "uploadDate": "2021-07-16T16:04:37Z",
            "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=3#rebelltitem3",
            "contentUrl": "https://youtu.be/0BQxuWujwiw",
            "embedUrl": "https://youtu.be/0BQxuWujwiw"
        }
    </script><script type="application/ld+json">
        {
            "@context": "https://schema.org",
            "@type": "VideoObject",
            "name": "M3NSA x M.anifest 'Question For The Gods'",
            "description": "\u003cp\u003eGhanaian rappers \u003cstrong\u003eM3NSA\u003c/strong\u003e and \u003cstrong\u003eM.anifest\u003c/strong\u003e connect for a new collaboration that asks many questions about social injustices while keeping things light and funny, throwing in some jokes everyone will relate to from daily life. They both really go in with their flows over this airy \u003cstrong\u003eRvdical The Kid\u003c/strong\u003e-produced beat. Get into it above.\u003c/p\u003e",
            "thumbnailUrl": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2MTQ3Ny9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzNDQzNjE1OX0.405QwJXdHPIaodaTwxNx4prMSjbwX4xTklZBjEeVfNg/img.jpg?width=980",
            "uploadDate": "2021-07-16T16:04:37Z",
            "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=2#rebelltitem2",
            "contentUrl": "https://youtu.be/wqoEy3pXRjw",
            "embedUrl": "https://youtu.be/wqoEy3pXRjw"
        }
    </script><script type="application/ld+json">
        {
            "@context": "https://schema.org",
            "@type": "VideoObject",
            "name": "Mr Drew 'Pains'",
            "description": "\u003cp\u003eGhana's buzzing \u003cstrong\u003eMr Drew \u003c/strong\u003eshares the new single and music video for his latest jam \"Pains.\" The track, produced by fellow Ghanaian \u003cstrong\u003eBeatz Vampire\u003c/strong\u003e, will grab your ears with its mix of afro-fusion and drill elements. It all makes for a hard-hitting song that we can see getting plenty of replays. \u003c/p\u003e",
            "thumbnailUrl": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjI0Mi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY3NzE3ODcwMX0.mwtjqYWNsyET02AEWK0U2Ot9yKGOlUSVNdidAY-C2xo/img.jpg?width=980",
            "uploadDate": "2021-07-16T16:04:37Z",
            "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=6#rebelltitem6",
            "contentUrl": "https://youtu.be/v969ZymMsyw",
            "embedUrl": "https://youtu.be/v969ZymMsyw"
        }
    </script><script type="application/ld+json">
        {
            "@context": "https://schema.org",
            "@type": "VideoObject",
            "name": "Yemi Alade 'Enjoyment'",
            "description": "\u003cp\u003eThe queen \u003cstrong\u003eYemi Alade\u003c/strong\u003e comes through over a fast-paced, \u003cstrong\u003eDr. Amir\u003c/strong\u003e-produced dance beat in her latest single \"Enjoyment.\" The track, as its title implies, is simply about enjoying one's self without remorse. Get into it above\u003c/p\u003e",
            "thumbnailUrl": "https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjk2NjIzNi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY1NDc5NTExNH0.MpMiyK9tSGFcuomXZJVkRsgayjLO-BUWkcvs7YKdiD8/img.jpg?width=980",
            "uploadDate": "2021-07-16T16:04:37Z",
            "url": "https://www.okayafrica.com/african-music-songs-mhd-olamide/?rebelltitem=4#rebelltitem4",
            "contentUrl": "https://youtu.be/e5jX2eYYvpY",
            "embedUrl": "https://youtu.be/e5jX2eYYvpY"
        }
    </script>


    <script class="lazy-style" type="css">
        

    </script>

    
        <script id="parsely-cfg" src="//cdn.parsely.com/keys/okayafrica.com/p.js"></script>
    <script id="user-javascript-medium-normal">
        window.REBELMOUSE_TASKS_QUEUE.push(function loadFonts(){});</script>
    <script id="user-javascript-active" type="text"></script>
    <script id="user-javascript-lowest" type="text">

window.REBELMOUSE_LOWEST_TASKS_QUEUE.push(function(){

    
        !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '581561272001865');
  fbq('track', 'PageView');
    

});

window.REBELMOUSE_LOWEST_TASKS_QUEUE.push(function(){

    
    window.REBELMOUSE_STDLIB.loadExternalScript("https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js", function() {
        
    });
    

});

window.REBELMOUSE_LOWEST_TASKS_QUEUE.push(function(){

    
        !function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '1764723736944867'); 
fbq('track', 'PageView');
    

});

window.REBELMOUSE_LOWEST_TASKS_QUEUE.push(function(){

    
        var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-6FjyzX7rRdcrz"
});
    

});

window.REBELMOUSE_LOWEST_TASKS_QUEUE.push(function(){

    
    window.REBELMOUSE_STDLIB.loadExternalScript("https://www.googletagservices.com/tag/js/gpt.js", function() {
        
    });
    

});</script>
</body>
</html>